aboutsummaryrefslogtreecommitdiffstats
path: root/web-project/pyproject.toml
diff options
context:
space:
mode:
authorEddy Pedroni <epedroni@pm.me>2025-02-21 06:55:30 +0100
committerEddy Pedroni <epedroni@pm.me>2025-02-21 06:55:30 +0100
commit2404f7b5507393bf2f8dcb60ba6886f3cda799aa (patch)
tree8a8f8f070665efe70902befa334a61c59542b7bf /web-project/pyproject.toml
parent655f5b87c43f4ac5cfaef6be482d652c532edc23 (diff)
Add wireframe of web interface, mock implementation in nicegui
Diffstat (limited to 'web-project/pyproject.toml')
-rw-r--r--web-project/pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/web-project/pyproject.toml b/web-project/pyproject.toml
new file mode 100644
index 0000000..440812e
--- /dev/null
+++ b/web-project/pyproject.toml
@@ -0,0 +1,24 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "solo_tool_web"
+authors = [
+ { name = "Eddy Pedroni", email = "epedroni@pm.me" },
+]
+description = "A NiceGUI-based web frontend for the solo_tool library"
+requires-python = ">=3.12"
+dependencies = [
+ "nicegui==2.11.1",
+ "solo_tool"
+]
+dynamic = ["version"]
+
+[project.optional-dependencies]
+dev = [
+]
+
+[project.gui-scripts]
+solo-tool-web = "solo_tool_web:main"
+