aboutsummaryrefslogtreecommitdiffstats
path: root/cli-project/pyproject.toml
diff options
context:
space:
mode:
authorEddy Pedroni <epedroni@pm.me>2024-11-09 20:35:56 +0100
committerEddy Pedroni <epedroni@pm.me>2024-11-09 20:35:56 +0100
commitcda8197669409689be291660f93cb288ab2d31b3 (patch)
tree81db9b0c7c0491e0737cbffb39af6b935c0dfeb8 /cli-project/pyproject.toml
parenta2257a900d4fffd6f94b73f1c48c62370ed1d684 (diff)
Migrate to project-based structure
Diffstat (limited to 'cli-project/pyproject.toml')
-rw-r--r--cli-project/pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/cli-project/pyproject.toml b/cli-project/pyproject.toml
new file mode 100644
index 0000000..7d31a09
--- /dev/null
+++ b/cli-project/pyproject.toml
@@ -0,0 +1,24 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "solo_tool_cli"
+authors = [
+ { name = "Eddy Pedroni", email = "epedroni@pm.me" },
+]
+description = "A CLI frontend for the solo_tool library"
+requires-python = ">=3.12"
+dependencies = [
+ "solo_tool"
+]
+dynamic = ["version"]
+
+[project.optional-dependencies]
+dev = [
+ "pytest"
+]
+
+[project.scripts]
+solo-tool-cli = "solo_tool_cli:main"
+