summaryrefslogtreecommitdiffstats
path: root/cli-project/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'cli-project/pyproject.toml')
-rw-r--r--cli-project/pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/cli-project/pyproject.toml b/cli-project/pyproject.toml
new file mode 100644
index 0000000..333c9cd
--- /dev/null
+++ b/cli-project/pyproject.toml
@@ -0,0 +1,19 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "flashcards_cli"
+authors = [
+ {name = "Eddy Pedroni", email = "epedroni@pm.me"},
+]
+description = "A CLI frontend for the flashcards library"
+requires-python = ">=3.12"
+dependencies = [
+ "click",
+ "flashcards"
+]
+dynamic = ["version"]
+
+[project.scripts]
+flashcard_cli = "flashcard_cli:cli"